Error: Could not load file or assembly ‘System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’ or one of its dependencies
Symptom
Error: Could not load file or assembly ‘System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’ or one of its dependencies.
Cause
This error message is a Microsoft .NET Framework error message. This error message may display on computers where Microsoft .NET Framework 2.0, Service Pack 2 is installed.
The Microsoft .NET Framework is the application layer SmartVault is written on. SmartVault requires the Microsoft .NET Framework in order to function properly.
This error message indicates that the System.EnterpriseServices.dll file cannot be found in the global access cache folder (WindowsAssembly) or the file is corrupt.
Resolution
To resolve this issue:
- If your computer is running Windows XP, click Start > Settings > Control Panel > Add/Remove Programs.
- If your computer is running Windows Vista, click Start > Control Panel > Programs.
- Scroll down to Microsoft .NET Framework SP2 and find KB259209.
- If KB959209 is not listed, go to http://support.microsoft.com/kb/959209 to download and obtain the fix.
- If your computer is running Windows XP, click Start > Run or type in
Runwhere it says Start. - If your computer is running Windows Vista, click Start > Run.
- Copy the following path into the Run or Search field:
C:WindowsMicrosoft.netFramework. - Select your version of the Microsoft .NET Framework (v2.0 or v2.0SP2).
- Find the
System.EnterpriseServices.dlland copy it by right-clicking on it and selecting Copy. - Click on Start > Run or type
Runwhere it says Start. - Copy this path into the Run or Search field:
C:WindowsAssembly. - Find the
System EnterpriseServices.dll, and rename it by right-clicking on it, selecting Rename, and adding the wordOLDin front of the name. (The file should look likeOLD_System.EnterpriseServices.dll.) - Right-click anywhere in the
Assemblyfolder and select Paste. (This will place the file you copied earlier in this folder.) - Close all windows.
- Restart your computer.
- Reinstall the SmartVault Desktop software.
Note: KB959209 contains updates for several different Windows operating systems. Ensure you download and install the correct update for your operating system.
Knowledge Base ID
KB189
