Error: This operation failed because the QueryInterface call on the COM component for the interface. Failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D)

Symptom

Error: This operation failed because the QueryInterface call on the COM component for the interface failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D)

Cause

This error message typically displays when some of the QuickBooks DLL associations become damaged or unregistered.

Resolution

To resolve this issue, re-register the QuickBooks files with Microsoft Windows by running the reboot.bat batch file.

To re-register the QuickBooks files with Microsoft Windows:

  1. Close QuickBooks.
  2. Exit out of the SmartVault Desktop software by right-clicking on the SmartVault icon in your system tray and then clicking Exit.
  3. Right-click the QuickBooks shortcut on your desktop, and then click Properties.
  4. Click the Open File Location button or the Find Target button.
  5. Scroll down the file list to find the file reboot or reboot.bat file, and then double-click the file.
  6. A DOS window will open and you will see a number of files being registered.

  7. When the batch file finishes running, close the DOS window.
  8. Remove the SmartVault security certficate by competing the following steps:
    1. Open QuickBooks.
    2. On the Edit menu, click Preferences.
    3. In the left pane, click Integrated Applications.
    4. On the Company Preferences tab, select SmartVault, and then click Remove.
    5. Note: If your SmartVault Desktop software has been upgraded from a version prior to SmartVault 3.0, you may need to remove both instances of SmartVault in the Integrated Applications dialog box.

    6. Click OK, and then click OK again.
    7. Close QuickBooks.
    8. Re-integrate SmartVault with QuickBooks.

    Knowledge Base ID

    KB181